[R] S4 : setGeneric for classical methods

Prof Brian Ripley ripley at stats.ox.ac.uk
Tue Jul 22 18:46:38 CEST 2008

On Tue, 22 Jul 2008, cgenolin at u-paris10.fr wrote:

> Hi the list (well, half of the list, only the one who are not on holidays...)
> I am trying to make an S4 package. When I run it on a console, everything 
> seems ok. When I run R CMD check, I got an error --- 8< 
> ----------------------
> Error in setMethod("plot", "ClassX", function(x, y) { :  no existing 
> definition for function "plot"
> --- 8< ----------------------
> If I add setGeneric("plot",function(x,y,...){standardGeneric("plot")})
> in my code, then everything is OK.
> This is a surprise for me since I taught that we do not need to redefine as 
> generic the function that are already generic, like "plot". Am I wrong ?

Yes. And do read the error message.  It says

 	no existing definition for function "plot"

so this is not if the function is S3 or S4 generic, but that no such 
function is visible.

Looks like you forgot to declare a dependence on (or import) package 

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

More information about the R-help mailing list