[R] Another failed attempt to install an R package in Ubuntu

Miklos Kiss mzkiss at gmail.com
Sat Jul 12 05:32:32 CEST 2008

I am running Ubuntu 8.04 through Wubi on a HP Pavilion dv4000 (my home
computer) and I recently installed R 2.7.1.  I attempted to install the
randomForest package from within the R environment and from the Linux
terminal.  Both attempts failed.  I've tried several mirrors but with no
luck.  Below is an example of the series of error messages I got when R told
me that the installation wasn't going well.

It tells me that several header files are missing.  For some reason it is
also trying to install them in '/home/mik/R/i486-pc-linux-gnu-library/2.7'
but my R library packages are located in '/usr/lib/R/library'.  I tried
downloading various x11dev packages and such, as suggested in similar
threads in this forum, but that didn't seem to help.

I'm really new (installed Ubuntu less than 4 months ago) to Linux but I've
been using R for about a year.  If anyone can point me in the right
direction on how to correctly install this package, I'd very much appreciate

Thank you,
Miklos Kiss

--- Please select a CRAN mirror for use in this session ---
Loading Tcl/Tk interface ... done
Warning in install.packages() :
  argument 'lib' is missing: using
trying URL 'http://cran.mtu.edu/src/contrib/randomForest_4.5-25.tar.gz'
Content type 'application/x-gzip' length 70212 bytes (68 Kb)
opened URL
downloaded 68 Kb

* Installing *source* package 'randomForest' ...
** libs
gcc -std=gnu99 -I/usr/share/R/include      -fpic  -g -O2 -c classTree.c -o
In file included from classTree.c:15:
/usr/share/R/include/R.h:28:20: error: stdlib.h: No such file or directory
/usr/share/R/include/R.h:29:19: error: stdio.h: No such file or directory
In file included from
                 from /usr/lib/gcc/i486-linux-gnu/4.2.3/include/limits.h:11,
                 from /usr/share/R/include/R.h:30,
                 from classTree.c:15:
/usr/lib/gcc/i486-linux-gnu/4.2.3/include/limits.h:122:61: error: limits.h:
No such file or directory
In file included from classTree.c:15:
/usr/share/R/include/R.h:32:18: error: math.h: No such file or directory
/usr/share/R/include/R.h:33:19: error: errno.h: No such file or directory
In file included from /usr/share/R/include/R.h:50,
                 from classTree.c:15:
/usr/share/R/include/R_ext/RS.h:24:39: error: string.h: No such file or
classTree.c: In function ‘catmax_’:
classTree.c:305: warning: implicit declaration of function ‘pow’
classTree.c:305: warning: incompatible implicit declaration of built-in
function ‘pow’
make: *** [classTree.o] Error 1
ERROR: compilation failed for package 'randomForest'
** Removing '/home/mik/R/i486-pc-linux-gnu-library/2.7/randomForest'

The downloaded packages are in
Warning message:
In install.packages() :
  installation of package 'randomForest' had non-zero exit status

View this message in context: http://www.nabble.com/Another-failed-attempt-to-install-an-R-package-in-Ubuntu-tp18415721p18415721.html
Sent from the R help mailing list archive at Nabble.com.

More information about the R-help mailing list