[R] installing on alpha

Martin Maechler maechler at stat.math.ethz.ch
Tue Sep 21 10:06:39 CEST 2004

>>>>> "Alexa" == Alexa Sorant <ajms at mail.nih.gov>
>>>>>     on Mon, 20 Sep 2004 17:35:43 -0400 writes:

    Alexa> I am trying to install R-1.9.1 on an alpha (Tru64 unix) platform.  I had no 
    Alexa> problem previously installing R-1.4.0, but cannot get the new installation 
    Alexa> to work.  First I ran "configure" specifying an alternate installation 
    Alexa> directory:
    Alexa> ./configure --prefix=/appl/R-1.9.1

We even recommend using an alternate *build* directory:

 mkdir <Rbuild>
 cd    <Rbuild>
 ../<Rsrc>/configure ....

and indeed, since R 2.0.0 is beta now (which means "testing" and
almost stable, not "unstable"!),
we'd appreciate (and feel more willing to support you) if you'd
tried to install R-2.0.0 directly.

    Alexa> then ran "make" (note that this is NOT gmake, which
    Alexa> may make the difference).  The error message I get is:
    Alexa> Make:  cannot open /share/make/vars.mk.  Stop.

    Alexa> The file share/make/vars.mk is there and readable,
    Alexa> but share is a subdirectory of the main installation
    Alexa> directory.  Upon examining Makefile and associated
    Alexa> files, I found a statement in Makeconf include
    Alexa> $(top_srcdir)/share/make/vars.mk which I suspected
    Alexa> was the problem -- perhaps the definition of
    Alexa> top_srcdir not is carrying over from the Makefile
    Alexa> that references Makeconf.

yes, that seems clear.  If your 'make' is not supporting such
'include' statements in Makefiles,  you definitely must use GNU
make (seemingly called 'gmake' on alpha) !

Did you look at the INSTALL file, or even consult the 
"R Administration and Installation" manual
(available from R-projec.org as well) ?

    Alexa> (One reason I suspect this statement is that it is new
    Alexa> since the version of R that I installed easily, as
    Alexa> well as the early reference to this particular file.)

    Alexa> I have tried a bunch of ways of modifying this
    Alexa> statement, including an explicit path in this
    Alexa> statement.  I think that did work, but a similar
    Alexa> problem then occurred at a later point that I haven't
    Alexa> yet located.

    Alexa> Has anyone gotten this installation to work on this platform?

    Alexa> Alexa J. M. Sorant
    Alexa> NIH/NHGRI
    Alexa> 333 Cassell Drive Suite 2000
    Alexa> Baltimore, MD 21224

    Alexa> ajms at mail.nih.gov

    Alexa> (410) 550-7512 voice
    Alexa> (410) 550-7513 fax

More information about the R-help mailing list