[R] unable to load shared library "/home/hpc1367/runs/taper/taper.so"

hpc1367 sje at mast.queensu.ca
Tue Sep 21 00:18:58 CEST 2004

I am trying to load a .so file and get the following error message:

> dyn.load("taper.so",local=F)
Error in dyn.load(x, as.logical(local), as.logical(now)) :
        unable to load shared library
  ld.so.1: /usr/local/lib/R/bin/R.bin: fatal: relocation error: file
/home/hpc1367/runs/taper/taper.so: symbol f90_init: referenced symbol
not found

also tried with default local=T and got same error.

my makefile (used to produce the .so) is included below

F90S = taper.f90
OBJS = taper.o
LIBS = -lsocket -lnsl -lintl
OPT = -fast
MODS = -M/opt/NAG/fnsol04dbl/nag_mod_dir
NAG = /opt/NAG/fnsol04dbl/libnagfl90.a

STATNAG = /opt/NAG/flsol20dal/libnag.a

taper.o : taper.f90
        f95 -c -dalign  $(OPT) $(MODS) taper.f90

taper.so: taper.f90
        f95 -o taper.so -G -dalign $(OPT) $(MODS) taper.f90

taper.x : taper.o
        f95 -o taper.x -dalign $(OPT) $(MODS) $(LIBS) taper.o $(OBJS)

please, help
thank you very much

More information about the R-help mailing list