[R] installing on alpha

Alexa Sorant ajms at mail.nih.gov
Mon Sep 20 23:35:43 CEST 2004

I am trying to install R-1.9.1 on an alpha (Tru64 unix) platform.  I had no 
problem previously installing R-1.4.0, but cannot get the new installation 
to work.  First I ran "configure" specifying an alternate installation 
         ./configure --prefix=/appl/R-1.9.1
then ran "make" (note that this is NOT gmake, which may make the 
difference).  The error message I get is:
         Make:  cannot open /share/make/vars.mk.  Stop.
The file share/make/vars.mk is there and readable, but share is a 
subdirectory of the main installation directory.  Upon examining Makefile 
and associated files, I found a statement in Makeconf
         include $(top_srcdir)/share/make/vars.mk
which I suspected was the problem -- perhaps the definition of top_srcdir 
not is carrying over from the Makefile that references Makeconf.  (One 
reason I suspect this statement is that it is new since the version of R 
that I installed easily, as well as the early reference to this particular 

I have tried a bunch of ways of modifying this statement, including an 
explicit path in this statement.  I think that did work, but a similar 
problem then occurred at a later point that I haven't yet located.

Has anyone gotten this installation to work on this platform?

Alexa J. M. Sorant
333 Cassell Drive Suite 2000
Baltimore, MD 21224

ajms at mail.nih.gov

(410) 550-7512 voice
(410) 550-7513 fax

More information about the R-help mailing list