[R] Package installation help: Stuck at "** byte-compile and prepare package for lazy loading"

Brodie, Kent brod|e @end|ng |rom mcw@edu
Wed Sep 29 23:11:14 CEST 2021

Hey everyone!  So, I've been asked by one of our researchers to install "all" cran packages on one of our servers.    Yeah, it's a bit much (and clearly, not everything will install correctly due to various missing tidbits), but it will go a long way to having to constantly respond to install requests of various packages.  OK, fine.

Anyway, I have tried this, and things proceed nicely for several hours until the process gets completely and absolutely stuck.   I have tried several things, for example trying newer versions of R, and even repeating the process on a CentOS 8 server instead of where my stuff is now (CentOS 7).

While re-trying one of my newer attempts at this, I decided to focus on the very first place where it hangs.   It dies on package "forensim".    It's a slightly older package, and I don't see anything particularly special about it.    The text below is where it hangs.    The install "R" process doing this is whizzing at 100%,  but no progress, no output, no errors.  Nothing in the system logs.

On new "R" installs, with either operating system (CentOS 7, CentOS 8) and even different versions of "R" (up to including 4.1.1), I get the same result when just attempting to install this ONE package.    (and my guess, there's more packages out there that may bite me the same way).

I am seeking any recommendations on how I can get past this?   A debug option?  A timeout of sorts so things will  move along to the next package when attempting to install a ton, or...?   I'm of course willing to try anything.   It's stupidly frustrating.    I'd be OK if it errored out and moved on.   But it...  hangs.

Here's the latter part of the install attempt of this one package.     This latest attempt has been stuck on that last line now for 5 hours and counting.

* DONE (tkrplot)
Making 'packages.html' ... done
* installing *source* package 'forensim' ...
** package 'forensim' successfully unpacked and MD5 sums checked
** using staged installation
** libs
gcc -m64 -I"/usr/include/R" -DNDEBUG   -I/usr/local/include   -fpic  -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -c auxilary.c -o auxilary.o
gcc -m64 -I"/usr/include/R" -DNDEBUG   -I/usr/local/include   -fpic  -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -c recursFinal.c -o recursFinal.o
gcc -m64 -shared -L/usr/lib64/R/lib -Wl,-z,relro -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -o forensim.so auxilary.o recursFinal.o -L/usr/lib64/R/lib -lR
installing to /usr/lib64/R/library/00LOCK-forensim/00new/forensim/libs
** R
** data
** inst
** byte-compile and prepare package for lazy loading

	[[alternative HTML version deleted]]

More information about the R-help mailing list