[R] installation problem on Ubuntu

Jeff Newmiller jdnewmil at dcn.davis.ca.us
Thu Apr 21 00:57:32 CEST 2016

Have you read the CRAN  instructions for installing on Ubuntu?  Have you read the Posting Guide that mentions the R-sig-debian mailing list and that if you need help compiling R this is not the right list?
Sent from my phone. Please excuse my brevity.

On April 20, 2016 9:36:51 AM PDT, Paul Tremblay <paulhtremblay at gmail.com> wrote:
>I needed to update R so I could install ggplot. I am running Ubuntu
>I cannot upgrade Ubuntu because I am using a work computer.
>I tried upgrading the normal way:
>sudo apt-get update
> sudo apt-get install r-base r-base-dev
>But this only installed an earlier version. Finally I tried installing
>source (./configure, Make install). This worked. However, when I try to
>install packages, I get this error:
>Error in download.file(url, destfile = f, quiet = TRUE) :
>  internet routines cannot be loaded
>In addition: Warning message:
>In download.file(url, destfile = f, quiet = TRUE) :
>  unable to load shared object '/usr/local/lib/R/modules//internet.so':
>/usr/local/lib/R/modules//internet.so: undefined symbol:
>>> ls /usr/local/lib/R/modules/
>>> R_X11.so  R_de.so  internet.so  lapack.so
>	[[alternative HTML version deleted]]
>R-help at r-project.org mailing list -- To UNSUBSCRIBE and more, see
>PLEASE do read the posting guide
>and provide commented, minimal, self-contained, reproducible code.

	[[alternative HTML version deleted]]

More information about the R-help mailing list