[R] installation problem on Ubuntu

Paul Tremblay paulhtremblay at gmail.com
Wed Apr 20 18:36:51 CEST 2016

I needed to update R so I could install ggplot. I am running Ubuntu 12.04.
I cannot upgrade Ubuntu because I am using a work computer.

I tried upgrading the normal way:

sudo apt-get update
 sudo apt-get install r-base r-base-dev

But this only installed an earlier version. Finally I tried installing from
source (./configure, Make install). This worked. However, when I try to
install packages, I get this error:

Error in download.file(url, destfile = f, quiet = TRUE) :
  internet routines cannot be loaded
In addition: Warning message:
In download.file(url, destfile = f, quiet = TRUE) :
  unable to load shared object '/usr/local/lib/R/modules//internet.so':
  /usr/local/lib/R/modules//internet.so: undefined symbol: curl_multi_wait

>> ls /usr/local/lib/R/modules/
>> R_X11.so  R_de.so  internet.so  lapack.so



	[[alternative HTML version deleted]]

More information about the R-help mailing list