[R] problem with R on mac os x

Peter Dalgaard p.dalgaard at biostat.ku.dk
Tue Dec 13 01:11:12 CET 2005

Eric Pante <ericpante at hotmail.com> writes:

> Hello all,
> R just ''stopped working'' on my machine (ibook g4, os 10.3.9). between 
> last time I used it and now, I did not do anything but check emails and 
> browse the internet. when I try to start the GUI, it appears and 
> disappears as rapidly. when I tried to run a session from the terminal, 
> I got the following:
> 	mkdir: /tmp/Rtmp590-29493: Permission denied
> 	mkdir: /tmp/Rtmp590: Permission denied
> 	ERROR: cannot create temporary R session directory
> If I log as root, I can start a session from the terminal, so I figured 
> that somewhere file permissions got corrupted. therefore, I 
> re-installed R (I tried 2.1.1 and 2.2.0), but same result: I can't 
> start a session. The install itself runs fine, though.
> Does anyone know what is going on? Where can I re-establish my 
> ''rights'' to use R ??? My R.app file is defined as drwxrwxr-x. I did 
> not see any mention of a similar problem in the archives.
> Thank you in advance for your insights!
> eric

Sounds like something doesn't have the right file permissions. Did the
/tmp/Rtmp* directories exist before R started? If not, what are the
permissions and ownership on /tmp?

We have had issues where we didn't quite succeed in creating temporary
directory names, but I'd expect such problems to be intermittent.

   O__  ---- Peter Dalgaard             Øster Farimagsgade 5, Entr.B
  c/ /'_ --- Dept. of Biostatistics     PO Box 2099, 1014 Cph. K
 (*) \(*) -- University of Copenhagen   Denmark          Ph:  (+45) 35327918
~~~~~~~~~~ - (p.dalgaard at biostat.ku.dk)                  FAX: (+45) 35327907

More information about the R-help mailing list