[R] No joy installing R with shared libs.

Aleksey Naumov naumov at buffalo.edu
Tue Sep 9 01:24:24 CEST 2003


I don't use RSPython, but I had the same problem with RPy: segfault in
python the moment I try to load RPy: 'import rpy'.
The problem happened in R 1.7.0 and was fixed by upgrading to R 1.7.1, I
think it was traced to conflicting regex functions in libc and R (see
http://rpy.sourceforge.net). So I'd try to install R 1.7.1 if you don't
have it...


On Mon, 8 Sep 2003 turner at uvs.is wrote:

> Hello,
> My platform is SuSE 8.1.  After downloading and unpacking R version 1.7 I 
> tried building with shared libs enabled. (./configure --enabl-R-shlib). My 
> goal is to use RSPython but I am now in my own private segmentation fault 
> hell.
> The R build worked fine: make, make check, make install cool.
> The RSPython build worked fine.
> Thinking I'm good to go, I run python. But when I import RS python rolls 
> over and dies with a segmentation fault. 
> It has been two days of futzing with recompiles, environment variable 
> diddling and whatnot. 
> Can some kind soul please give me a fool proof recipe for building R and 
> RSPython so that it actually works?
> Thanks,
> Douglass Turner
> 	[[alternative HTML version deleted]]
> ______________________________________________
> R-help at stat.math.ethz.ch mailing list
> https://www.stat.math.ethz.ch/mailman/listinfo/r-help

More information about the R-help mailing list