[R] X11 not available

Marc Schwartz MSchwartz at medanalytics.com
Mon Sep 8 05:37:50 CEST 2003

On Sun, 2003-09-07 at 20:18, Jose Quesada wrote:


> Thanks Marc,
> That worked fine. A bunch of dependencies were detected when trying to 
> install XFree86-devel-4.3.0-2. I tried to solve them, and installed some 
> newer versions exisiting libraries, concretely:
> XFree86-devel-4.3.0-25.i386.rpm
> XFree86-libs-4.3-5mdk.i586.rpm
> XFree86-libs-4.3.0-2.i386.rpm
> XFree86-libs-4.3.0-25.i386.rpm
> XFree86-libs-data-4.3.0
> fontconfig-2.2.1-6mdk.i586.rpm
> fontconfig-devel-2.2.1-4.i386.rpm
> freetype-2.1.4-4.1.i386.rpm
> freetype-devel-2.1.4-4.1.i386.rpm
> Some dependencies were recursive (A needed B installed, B needed A to be 
> installed), so I had to run rpm --nodeps (which is not a good practice). 
> After an uninstall and reinstall fest, I have R working with Xwindows... 
> but no other program can find X anymore :|. I still prefer that to having 
> R with no X11, but if you have any advice to reinstall the newer XFree 
> + devel libraries in a clean way, without breaking dependencies, please 
> let me know!
> Thanks a lot again,
> -Jose


The RPMs that have 'mdk' in them are for the Mandrake distribution and
not for Red Hat. I presume that you may have downloaded those from
RPMFind or RPMSeek? You now likely have a mix of conflicting RPMs on
your system, which is problematic as you are finding.

You will need to uninstall those RPMs and perhaps the others that you
installed (using rpm -e RPMName) and install the Red Hat versions. These
should be on your Red Hat install CD's.  If you get dependency issues
during the removal, use rpm -e RPMName1 RPMName2 ..., where you list
multiple RPMs as part of the same command. That will enable the RPM
manager to handle the dependencies during removal.

If X is still intact and running after the uninstall process, an easy
way of doing the install step for the devel packages is to go to the
Main Red Hat menu, then to System Settings, then to Add/Remove
Applications.  This will then prompt you for the root password.

Once this is up, it will bring you to the Package Management menu. In
that menu will be a category of Development. Select Development Tools,
Kernel Development, X Software Development and Gnome Software
Development (also KDE if you use that). Once you have selected these,
then click on update. This will install the requested RPMs while taking
care of the various dependencies. You will need to have your Red Hat
installation CD's for this process.

If this proceeds successfully, you will have the development packages
installed for the key system components, which will enable you to
compile applications from source or source RPMs.

The particular X related RPMS that you should have, out of the list
above are:


These are the most recent Red Hat released versions of these RPMs.

As you noted, it is bad to use --nodeps, as this can result in a variety
of problems and compromise the integrity of the RPM database, which can
lead to future problems with updates and related operations. Typically
if there are multiple RPMs that are co-dependent, you can put them into
a common directory and use 'rpm -Uvh *rpm' without the quotes. Then the
RPM manager will handle the various dependencies during the install.

Depending upon the state of your system after uninstalling the
conflicting RPMS, you may or may not be able to run X. If not, you may
have to resort to restarting your system in console mode and
re-installing the RPMs. If things get really bad, you may need to
re-boot to a rescue disk (should have been created during the initial
install) or to the original boot CD to be able to get to a console so
that you can login as root to reinstall the compromised RPMs.

Until you get there, it may be difficult to know what steps you might
have to take to get back to a stable system.

Drop a line back with any updates.



More information about the R-help mailing list