[R] "Tcl/Tk support is not available on this system, " RH 9, R 1.7.0-1

Marc Schwartz MSchwartz at medanalytics.com
Mon May 26 19:54:27 CEST 2003

Prof. Baron,


rpm -qa | grep tcl


rpm -qa | grep tk

in a console and look for the following from the first and second
outputs respectively:


The above are the latest versions of tcl and tk "officially" released by
RH for 9, though if you installed new RPMs as you indicate below, you'll
get the versions reported from them.

Depending upon what type of install you did with RH 9, you may or may
not have had these prior to installing R.  As Prof. Ripley pointed out,
these need to be present when you installed the R 1.7.0 RPM.

I just installed Rcmdr on my RH 9 system and it works fine (albeit only
during a first look with no extensive testing), so my guess is that you
are or were missing the tcl/tk packages when you installed R. Be aware
that you also need the "car" package installed from CRAN for Rcmdr.

You may need to remove R 1.7.0 and reinstall it with the RH tcl/tk
packages present.

I am going to be at my computer somewhat infrequently today, but if I
can be of help, let me know.


Marc Schwartz

P.S. to Prof. Fox: Unless I missed it, you may wish to consider having
an adjustment for the font size on the menus. When using
options(Rcmdr.fontsize = XX), it affected the log window size, but not
the menu fonts, which on my 1600 x 1200 lcd panel are on the smallish

On Mon, 2003-05-26 at 11:17, Prof Brian Ripley wrote:
> How did you install R?  `R-1.7.0-1' suggests a binary RPM, but we
> shouldn't have to guess.
> Tcl/Tk has to be present when R was configured.  My guess is that was not 
> so when your R was configured (I think RH8.0 and 9 by default don't have 
> Tcl/Tk, and never have the current 8.4.1).  In that case you need to build 
> R yourself: always a good idea.
> It isn't clear to the rest of us what options the builders of binary RPMs 
> include, and it would be helpful if the summary given at the end of 
> configure was available on CRAN.
> On Mon, 26 May 2003, Jonathan Baron wrote:
> > In trying to run John Fox's new Rcmdr package on Redhat Linux 9,
> > I got this error message.  The problem is in loading the tclck
> > library.  library(tcltk) produces the same error.  It has been
> > discussed before, e.g.,
> > http://finzi.psych.upenn.edu/R/Rhelp02/archive/11898.html but
> > with respect to earlier versions of Linux and R.
> > I tried updating to the latest RPMs of tcl and tk (8.3.5-89), but
> > that didn't help.  Otherwise I just have the standard RH9
> > installation.  Has anyone gotten tcltk to work on RH9?

More information about the R-help mailing list