[R] "Tcl/Tk support is not available on this system, " RH 9, R 1.7.0-1

Prof Brian Ripley ripley at stats.ox.ac.uk
Mon May 26 18:17:05 CEST 2003

How did you install R?  `R-1.7.0-1' suggests a binary RPM, but we
shouldn't have to guess.

Tcl/Tk has to be present when R was configured.  My guess is that was not 
so when your R was configured (I think RH8.0 and 9 by default don't have 
Tcl/Tk, and never have the current 8.4.1).  In that case you need to build 
R yourself: always a good idea.

It isn't clear to the rest of us what options the builders of binary RPMs 
include, and it would be helpful if the summary given at the end of 
configure was available on CRAN.

On Mon, 26 May 2003, Jonathan Baron wrote:

> In trying to run John Fox's new Rcmdr package on Redhat Linux 9,
> I got this error message.  The problem is in loading the tclck
> library.  library(tcltk) produces the same error.  It has been
> discussed before, e.g.,
> http://finzi.psych.upenn.edu/R/Rhelp02/archive/11898.html but
> with respect to earlier versions of Linux and R.
> I tried updating to the latest RPMs of tcl and tk (8.3.5-89), but
> that didn't help.  Otherwise I just have the standard RH9
> installation.  Has anyone gotten tcltk to work on RH9?

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

More information about the R-help mailing list