[R] arulesSequences Package

Jeff Reichman re|chm@nj @end|ng |rom @bcg|ob@|@net
Tue Oct 2 02:02:33 CEST 2018

I Was able to figure out how to create my object using the "read_baskets"
function but when I run the "cspade" function I receive the following error
(running in RStudio)
4 -> 1 2 -> 1 -> 1 -- 1 1 
3 -> 1 2 -> 1 -> 1 -- 1 1 
3 4 -> 1 2 -> 1 -> 1 -- 1 1 
3 4 -> 1 -> 1 -> 1 -- 1 1 
 NA MB [2.4s]
reading sequences ...Error in file(con, "r") : cannot open the connection
In addition: Warning message:
In file(con, "r") :
  cannot open file
f8c30bb5148.out': No such file or directory
> cspade> as(s1, "data.frame")
Error in .class1(object) : object 's1' not found

But if I run in R (alone) it works just fine.  Any idea why I can' t seem to
run in RStudio or what I might have to do in RStudio?

-----Original Message-----
From: R-help <r-help-bounces using r-project.org> On Behalf Of Jeff Reichman
Sent: Monday, October 1, 2018 4:48 PM
To: r-help using r-project.org
Subject: [R] arulesSequences Package

R-Help Forum

For anyone who has used the "arulesSequences" Package how do I start with
raw data (*.csv file) and convert into a sequence object to run the cSPADE
function.  The package example use zaki dataset which has already been
converted.  When I state raw data how should I structure my csv file?

A web example  or RPubs link?

For example 
Seq_1	{E,B}, {C}, {T}
Seq_2 	(E,M}, {C}, {B,E,V,T}
Seq_3 	{E},{C},{T}

Jeff Reichman

R-help using r-project.org mailing list -- To UNSUBSCRIBE and more, see
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list