[R] Error with "compiler" and "caret" packages

Bert Gunter bgunter.4567 at gmail.com
Thu Jan 26 19:25:38 CET 2017

Check your permissions? They may be denying your process access.

Bert Gunter

"The trouble with having an open mind is that people keep coming along
and sticking things into it."
-- Opus (aka Berkeley Breathed in his "Bloom County" comic strip )

On Wed, Jan 25, 2017 at 3:23 PM, Jeff Hughes <jeff.hughes at gmail.com> wrote:
> Hi there,
> I have been getting an irritating error when trying to use the "caret"
> package on one of my machines. Whenever I train any model whatsoever, it
> comes back with this error:
> Warning: namespace ‘compiler’ is not available and has been replaced
> by .GlobalEnv when processing object ‘sep’
> Error in comp(expr, env = envir, options = list(suppressUndefined = TRUE))
> :
>   could not find function "makeCenv"
> As a result, the model does not work, and I am unable to use the caret
> package. As an example, here is some code that causes the error, though it
> has happened in every case I have tried:
> library(caret)
> fit.knn <- train(Species ~ ., data=iris, method="knn")
> I have tried reinstalling the caret package; I have tried reinstalling R; I
> have tried updating all of my packages; nothing has worked. What's more,
> this machine is running Windows 10, and I have successfully run the same
> code on two other machines running the same version of Windows, the same
> version of R, and the same version of the caret package. I have also only
> run into it when using caret, but I don't think the error lies within that
> package itself.
> Here is my sessionInfo() after running the above code in a new R session:
> R version 3.3.2 (2016-10-31)
> Platform: x86_64-w64-mingw32/x64 (64-bit)
> Running under: Windows >= 8 x64 (build 9200)
> locale:
> [1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United
> States.1252    LC_MONETARY=English_United States.1252
> [4] LC_NUMERIC=C                           LC_TIME=English_United
> States.1252
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods   base
> other attached packages:
> [1] caret_6.0-73    ggplot2_2.2.1   lattice_0.20-34
> loaded via a namespace (and not attached):
>  [1] Rcpp_0.12.8        magrittr_1.5       splines_3.3.2      MASS_7.3-45
>      munsell_0.4.3      colorspace_1.3-2
>  [7] foreach_1.4.3      minqa_1.2.4        stringr_1.1.0      car_2.1-4
>      plyr_1.8.4         tools_3.3.2
> [13] parallel_3.3.2     nnet_7.3-12        pbkrtest_0.4-6     grid_3.3.2
>       gtable_0.2.0       nlme_3.1-128
> [19] mgcv_1.8-16        quantreg_5.29      e1071_1.6-7        class_7.3-14
>       MatrixModels_0.4-1 iterators_1.0.8
> [25] lme4_1.1-12        lazyeval_0.2.0     assertthat_0.1     tibble_1.2
>       Matrix_1.2-7.1     nloptr_1.0.4
> [31] reshape2_1.4.2     ModelMetrics_1.1.0 codetools_0.2-15   stringi_1.1.2
>      scales_0.4.1       stats4_3.3.2
> [37] SparseM_1.74
> Note that the "compiler" package is not loaded for some reason, which I
> think it should be (the other machines on which this runs successfully have
> it loaded). But the compiler package is built-in, so I can't seem to find a
> way to load it manually.
> This one has really stumped me, and there are very few relevant hits on
> Google. Any help would be much appreciated!
> Jeff
>         [[alternative HTML version deleted]]
> ______________________________________________
> R-help at r-project.org mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list