[R] Error in loadNamespace

David Winsemius dwinsemius at comcast.net
Thu Dec 7 20:19:46 CET 2017

> On Dec 7, 2017, at 10:47 AM, James Henson <jfhenson1 at gmail.com> wrote:
> Hello R Community,
> I inadvertently updated packages via R Studio when a package was open.  Now
> when R Studio is opened the message below appears in the console panel.
> Error in loadNamespace(name) : there is no package called ‘yaml’
> Error in loadNamespace(name) : there is no package called ‘yaml’
> When running R code, so far the only function that has not worked is
> datatable () in the ‘DT’ package.  Removing the ‘DT’ package and
> reinstalling it had no effect.  A possible fix is to update R from an older
> version, which was not running when I made the mistake.  Is this a good
> idea?

There is a package on CRAN named "yaml". Have your tried installing it?
> Thanks for your help.
> James F. Henson
> 	[[alternative HTML version deleted]]

Rhelp is a plain text mailing list.

> ______________________________________________
> R-help at r-project.org mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

David Winsemius
Alameda, CA, USA

'Any technology distinguishable from magic is insufficiently advanced.'   -Gehm's Corollary to Clarke's Third Law

More information about the R-help mailing list