[R] JAGS 4.x, rjags 4.x problems | Linux -- solved

Rainer Hurling rhurlin at gwdg.de
Thu Nov 5 18:25:19 CET 2015

Am 05.11.2015 um 15:44 schrieb Evan Cooch:
> Well, sort of. I got sufficiently frustrated that I completely
> uninstalled R, jags, and everything related. Did a re-install using only
> versions of R nd JAGS found in the epel repo. No muss, no muss -- all
> works.
> Out of curiosity, uninstalled again, and tried my usual sequence of
> manually compile R from source, same with JAGS. R works, JAGS works, but
> can't get any R package linking the two (say, rjags, R2jags), to
> recognize that JAGS is installed.
> Ah well, at least the 'install from repos' approach works. I'll have to
> make do with that.

Just took another look in my installation call, I made some time ago.
What I did to get it work on FreeBSD was:

R CMD INSTALL rjags_4-4.tar.gz --configure-args='CPPFLAGS="-fPIC"
LDFLAGS="-L/usr/local/lib -ljags"
--with-jags-include=/usr/local/include/JAGS --with-jags-lib=/usr/local/lib'

So I used --configure-args, LDFLAGS, --with-jags-inlcue and
--with-jags-lib in my installation procedure. Perhaps it is worth
another try?

More information about the R-help mailing list