[R] What happened to Canada?

Rolf Turner r.turner at auckland.ac.nz
Tue Nov 3 00:40:37 CET 2015

Thanks for the reply, Marc.

On 03/11/15 12:09, Marc Schwartz wrote:


> Rolf,
> What do:
>    getOption("CRAN")
>    getOption("repos")
> show?

The first shows "NULL", the second shows

> "http://cran.stat.auckland.ac.nz"

> Is there any chance that you have something set in ~/.Rprofile
> pertaining to CRAN mirrors or are loading some packages that might conflict?

Indeed.  I have "repos" set (as seen above) in my .Rprofile.

> I would try it with a vanilla R session (e.g. 'R --vanilla').

I had already tried "R --vanilla" and got the same effect.  I.e. I got 
the same error from chooseCRANmirror() but nevertheless the menu 
appeared, just as before.

This time, at your prompting, I tried to install a package under
"R --vanilla":

> install.packages("circular",lib="/home/rolf/Rlib")

I got the following warning message(s):

> Warning: unable to access index for repository
> https://cran.r-project.org/src/contrib
> Warning message:
> package ‘circular’ is not available (for R version 3.2.2)

(That last warning is certainly not true.)

Note that this was *after* having chosen the Austria mirror from the 
menu presented by chooseCRANmirror().

Before running chooseCRANmirror(), getOption("repos") produced:

>     CRAN
> "@CRAN@"

After running chooseCRANmirror(), getOption("repos") produced:

>                         CRAN
> "https://cran.r-project.org"

> If it works then, there is something getting loaded or set at session
> start that may be conflicting.

Well, it *doesn't* work, so setting "repos" in my .Rprofile was not the 
problem, or at least not the essence of the problem.

Any other ideas?  Ta.



Technical Editor ANZJS
Department of Statistics
University of Auckland
Phone: +64-9-373-7599 ext. 88276

More information about the R-help mailing list