[R] Cannot run install binary package on Windows 8

Maciej Węgorkiewicz wegorkie at gmail.com
Sat Apr 11 19:39:41 CEST 2015

Hi all,

I am just starting with R and cannot use "lmtest" package on Windows 8.
This package contains dwtest function that I am interested in.

I began with installing the core of R (with rgui) - version 3.1.3 64-bit.

Then I installed lmtest package using GUI menu, but after success
message I cannot run dwtest() getting message that the it cannot find
the function.

When I used installed.packages() function I saw lmtest on the list but
there was "yes" under the "NeedsCompilation" column. Does it mean I
need to compile the package in order to use it?

I uninstalled lmtest and tried to put binary Windows version by
downloading zip file from here:

I took the file:

downloaded it and tried to use the function of installing from local zip file.

However the effect was the same: "NeedsCompilation" set to true,
dwtest does not work.
The package contains binary file for 64-bit (DLLs).

What can I do in order to run this?

More information about the R-help mailing list