[R] Repeated failures to install "caret" package (of Max Kuhn)

Ronald Wyllys wyllys at ischool.utexas.edu
Fri Apr 3 23:07:57 CEST 2015

For an edx course, MIT's "The Analtics Edge", I need to install the 
"caret" package that was originated and is maintained by Dr. Max Kuhn of 
Pfizer. So far, every effort I've made to try to 
install.packages("caret") has failed.  (I'm using R v. 3.1.3 and RStudio 
v. 0.98.1103 in LinuxMint 17.1)

Here are some of the things I've tried unsuccessfully:
install.packages("caret", repos=c("http://rstudio.org/_packages", 
install.packages("caret", dependencies=TRUE)
install.packages("caret", repos=c("http://rstudio.org/_packages", 
"http://cran.rstudio.com"), dependencies=TRUE)
install.packages("caret", dependencies = c("Depends", "Suggests"))
install.packages("caret", repos="http://cran.rstudio.com/")

I've changed my CRAN mirror from UCLA to Revolution Analytics in Dallas, 
and tried the above installs again, unsuccessfully.

I've succeeded in individually installing a number of packages on which 
"caret" appears to be dependent.  Specifically, I've been able to 
install  "nloptr", "minqa", "Rcpp", "reshape2", "stringr", and 
"scales".  But I've had no success with trying to do individual installs 
of "BradleyTerry2", "car", "lme4", "quantreg", and "RcppEigen".

Any suggestions will be very gratefully received (and tried out quickly).

Thanks in advance.

Ron Wyllys

More information about the R-help mailing list