[R] Failure with .Rprofile on Mac OS X

David Winsemius dwinsemius at comcast.net
Fri Sep 19 06:57:49 CEST 2014

Dear Gang Chen;

The .Rprofile is loaded from the startup directory. Terminal.app will  
start up in /Applications/ while your R.app session appears to be  
starting in a different directory. (We don't know what your startup  
directories are.)  I'm using R.app in /Applications/ so my .Rprofile  
has the same effect regardless of whether I run from R.app or from a  
bash console.

See this portion of the Mac-FAQ:


  See ?Startup for more specifics that are generic to all R versions:

On Sep 18, 2014, at 7:04 PM, Amos B. Elberg wrote:

> The only reason that *should* happen is if there's an .Rprofile in  
> the directory you're in when you start R.
> Where *exactly* is the .Rprofile file you want loaded, what  
> directory are you starting from, and what does R say is the user's  
> home directory? Did you make *any* changes to Rprofile.site, or  
> Renviron?
> What is the output from Sys.getenv() in gui and cli, and do they  
> differ?

They might differ even if the default directories are the same (as  
they are on my setup). I have a somewhat older version on this laptop  
but there are names of environment variables that are not present in  
both directions:

I ran AppEnv <- dput( Sys.getenv() ) on my R.app session and then ran  
the corresponding command on a Terminal console session:

These are the difference (on a R 2.15.2 setup):

 > AppEnv[ !names(AppEnv) %in% names(conEnv)]
             "6435"             "1.53"
 > names( conEnv[ !names(conEnv) %in% names(AppEnv)] ) # i.e. missing  
in the GUI installation

  [1] "COLUMNS"              "DYLD_LIBRARY_PATH"     
  [5] "LINES"                "MANPATH"               
"PERL5LIB"             "PWD"
  [9] "SHLVL"                "TERM"                  
[13] "XDG_CACHE_HOME"       "XDG_CONFIG_DIRS"       

  If there are further points of discussion they should be thrashed  
out (with greater details about sessionInfo() and startup settings),  
over on the R-MAC-SIG mailing list.

>> On Sep 18, 2014, at 11:18 AM, Gang Chen <gangchen6 at gmail.com> wrote:
>> When R starts in GUI (e.g., /Applications/R.app/Contents/MacOS/R) on
>> my Mac OS X 10.7.5, the startup configuration in .Rprofile works  
>> fine.
>> However, when R starts on the terminal (e.g.,
>> /Library/Frameworks/R.framework/Resources/bin/R), it does not work at
>> all. What could be the reason for the failure?
>> Thanks,
>> Gang

David Winsemius, MD
Alameda, CA, USA

More information about the R-help mailing list