[R] parallels package -can't create cluster

Carl Witthoft carl at witthoft.com
Tue Oct 8 23:35:07 CEST 2013

I am trying to use the parallel package, and found that makeCluster 
hangs (and no apparent actions have taken place). This is Windows7-64, 
"Enterprise", R 3.0.1 .

I've traced the hang to the following line in newPSOCKnode :

con <- socketConnection("localhost", port = port, server = TRUE,
     blocking = TRUE, open = "a+b", timeout = timeout)
That command stalls. My suspicion is this is due to some "overzealous IT 
rules" laid down on our work computers, but would welcome any 
suggestions as to how to trace (and fix) the source of the problem.

While in debug mode, I did a dump just before the socketConnection call:

Browse[3]> ls.str()
arg :  chr "parallel:::.slaveRSOCK()"
cmd :  chr 
"\"C:/Users/carl.witthoft/Documents/R/R-3.0.1/bin/x64/Rscript\" -e 
\"parallel:::.slaveRSOCK()\" MASTER=localhost PORT=11017 OUT="| 
env :  chr "MASTER=localhost PORT=11017 OUT=/dev/null TIMEOUT=2592000 
machine :  chr "localhost"
manual :  logi FALSE
master :  chr "localhost"
methods :  logi TRUE
options : <environment: 0x000000000ccac6a0>
outfile :  chr "/dev/null"
port :  int 11017
rank :  int 1
renice :  int NA
rscript :  chr 
timeout :  num 2592000
useXDR :  logi TRUE

Other possibly useful info:

I opened a shell and ran
netsh advfirewall firewall add rule name="Open Port 11017" dir=in 
action=allow protocol=TCP localport=11017

and got an "OK" response. I ran netstat -a -n and found the following line:


But running makePSOCKcluster still hangs at the same place.

NEXT: I tried running R from the command line (via cygwin bash), and the 
error message I get is

Error in loadhistory(file) : no history mechanism available Execution 

, after which ctrl-C returns me to the R-prompt.


Sent from a parallel universe almost, but not entirely,
nothing at all like this one.

More information about the R-help mailing list