[R] Linux Java and R not working together

Uwe Bohne balu555 at gmx.de
Wed Nov 13 11:22:00 CET 2013

   Dear community,

   I almost tried for 3 days now to install rJava and package FSelector on my
   Linux machine but couldn't do so.
   I  searched all the forums and tried some tricks ... but unfortunately
   couldn't find any solution.
   First of all I did try to install rJava in my rkward without any changes ,
   that gave me the following error :

   configure: error: One or more JNI types differ from the corresponding native
   type.  You  may need to use non-standard compiler flags or a different
   compiler in order to fix this.

   ERROR: configuration failed for package ‘rJava’

   * removing ‘/home/uwe/.rkward/library/rJava’


   In install.packages(pkgs = c("rJava"), lib = "/home/uwe/.rkward/library", :

   Installation des Pakets ‘rJava’ hatte Exit-Status ungleich 0

   So then I started searching and found a tip. I did run the following;

   uwe at linux-k2a8:~> sudo R CMD javareconf
   Java interpreter : /usr/bin/java
   Java version     : 1.7.0_45
   Java home path   : /usr/lib/jdk1.7.0_45/jre
   Java compiler    : /usr/bin/javac
   Java headers gen.: /usr/bin/javah
   Java archive tool: /usr/bin/jar
   NOTE: Your JVM has a bogus java.library.path system property!
         Trying a heuristic via sun.boot.library.path to find jvm library...
   Java library path: $(JAVA_HOME)/lib/i386/client
   JNI linker flags : -L$(JAVA_HOME)/lib/i386/client -ljvm
   JNI cpp flags    : -I$(JAVA_HOME)/../include -I$(JAVA_HOME)/../include/linux
   Updating Java configuration in /usr/lib/R

   And also did check 

   uwe at linux-k2a8:~> java -version
   java version "1.7.0_45"
   Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
   Java HotSpot(TM) Server VM (build 24.45-b08, mixed mode)
   uwe at linux-k2a8:~> sudo /usr/sbin/update-alternatives --config java
   There are 4 choices for the alternative java (providing /usr/bin/java).
     Selection    Path                                     Priority   Status
     0            /usr/lib/jvm/jre-1.7.0-openjdk/bin/java   17147     auto mode
     1            /usr/java/latest/bin/java                 1         manual
   * 2            /usr/lib/jdk_Oracle/bin/java              3         manual
     3            /usr/lib/jvm/jre-1.5.0-gcj/bin/java       1500      manual
     4            /usr/lib/jvm/jre-1.7.0-openjdk/bin/java   17147     manual
   Press enter to keep the current choice[*], or type selection number:

   I absolutely don't know what is wrong with that setup since my Java seems to
   have JDK and all the other things needed for R.

   For your Information here my system:
   uwe at linux-k2a8:~> uname -rm
   3.4.63-2.44-desktop i686

   uwe at linux-k2a8:~> cat /proc/version
   Linux version 3.4.63-2.44-desktop (geeko at buildhost) (gcc version 4.7.1
   20120723 [gcc-4_7-branch revision 189773] (S Linux) ) #1 SMP PREEMPT Wed Oct
   2 11:18:32 UTC 2013 (d91a619)

   I would be really thankful for any advise to get rJava (and FSelector)
   running soon.

   Best wishes


More information about the R-help mailing list