[R] R with openblas and atlas

Li Bowen bowenli37 at gmail.com
Fri Nov 1 05:34:04 CET 2013


I have been trying to build R with optimized BLAS library.

I am using a Ubuntu 13.10 x86_64 desktop, on which I am able to build R
with openblas without any problem:

./configure --enable-BLAS-shlib --enable-R-shlib LIBnn=lib --disable-nls --with-blas="-L/usr/lib/openblas-base/ -lopenblas" --enable-memory-profiling
sudo make install

However, on redhat 5.9, I am not able to install openblas.
Firstly, there is no pre-built package, even for later version of
Secondly, I am not able to build openblas from source, actually not even
able to install newer gcc from source.

I then tried to install ATLAS on redhat and build R with it. -t 2: 2 threads
../configure --shared -t 2 -b 64 -D c -DPentiumCPS=1600
make build
make check
make ptcheck
make time
make install

# R
../configure --enable-BLAS-shlib --enable-R-shlib --disable-nls
--enable-memory-profiling --with-blas="-L/usr/local/atlas/lib
-lptf77blas -lpthread -latlas"
sudo make install

Installation is successful. However when I run the following code, only
one thread is used.

I have looked through lots of manuals and forums and couldn't find an
answer. Please advise. Thanks a lot.


More information about the R-help mailing list