[R] Issues with TMPDIR/TEMP/TMP? Failure of R CMD check under Windows 7

Ulrike Grömping groemping at bht-berlin.de
Sun Feb 24 22:34:06 CET 2013

Am 24.02.2013 22:14, schrieb Duncan Murdoch:
> On 13-02-24 4:00 PM, Ulrike Grömping wrote:
>> Dear helpeRs,
>> on my Windows 7 laptop, I have problems getting R CMD check to work. I
>> believe it did work completely before, but I am not sure.
>> Yesterday it almost worked, except for the tests: These were aborted
>> because of a complaint that the temporary directory wasn't available. I
>> played with windows environment variables for the temporary directory,
>> but that didn't solve it. Apparently I did something that made things 
>> worse:
>> Today, R CMD check completely refuses to work, with the error message
>> "Fatal error: creation of tmpfile failed -- set TMPDIR suitably?" This
>> is the same for current R and R-devel. Changes to the TEMP or TMP
>> environment variable don't influence this behavior.
>> The path:
>> C:\Rtools;C:\Program Files\Dell\DW WLAN Card;C:\Program
> With the default install, there are no executables in C:\Rtools. They 
> are normally in C:\Rtools\bin and C:\Rtools\gcc-4.6.3\bin. But this 
> probably isn't causing the problem.  It sounds as though you've set 
> the temporary directory to something that doesn't exist, or somewhere 
> you're not allowed to write.
> Can you still start R?  If so, what does tempdir() show?  Mine shows
> [1] "C:\\temp\\RtmpGeoCGq"
> The random bit at the end would be different for each session. The 
> part before needs to be a path in which you have write permission.
Actually, I can't start R any more (Error: mkdir R_TempDir does not 
work). And it appears that changing the TEMP and TMP environment 
variables in Windows does not really affect the choice of TempDir in R ? 
Yesterday, the complaint was always related to a random directory name 
within the default temporary directory, and there are many such 
directories in that path (I would have thought that these are deleted 
when shutting the machine down, but apparently the are not), so there 
must have been write permission in there once. Today everything is 
different, perhaps because of something I did yesterday but don't 
remember any more.

If all else fails, I suppose the fastest thing may be a complete 
re-install of R.

Best, Ulrike

>> Files\R\R-2.15.2\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program 
>> Files\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files\WIDCOMM\Bluetooth
>> Software\;C:\Program Files\Calibre2\;C:\Program Files\MiKTeX
>> 2.9\miktex\bin\;C:\Program Files\TortoiseSVN\bin
>> Any ideas what I can do to fix this?
>> Perhaps also relevant: I run R CMD check from a DOS window that is
>> opened with administrator rights.
> You should start R from the same window, using just "R" or "Rgui" to 
> make sure it sees the same environment.
> Duncan Murdoch
>> Best, Ulrike
>> ______________________________________________
>> R-help at r-project.org mailing list
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide 
>> http://www.R-project.org/posting-guide.html
>> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list