[R] RPostgreSQL libpq problem

Bunny, lautloscrew.com bunny at lautloscrew.com
Fri Aug 28 16:17:36 CEST 2009

Dear all,

I am stuck trying to get RPostgreSQL running on my Mac. PostgreSQL  
itself does work fine as it is able to connect with various other apps.
Unfortunately the RPostgreSQL package is not available as a binary for  
MAC OS. Thus I´ve been trying to compile the source for quite some  
time now - unfortunately without success (or at least very limited  

First,  running ./configure  respectively running the installation  
directly via R was not able to find the header file libpq-fe.h. after  
I changed PG_INCDIR to my
local postgre dir the error message disappear and i got another one:

ld: library not found for -lpq

Thus I tried to set PG_LIBDIR to the directory where libpq is located,  
but still I received the same error message, despite a encouraging  
libpq-fe.h ...yes

Does anybody know how to fix this?

Thx in advance


More information about the R-help mailing list