[R] Problem with RHEL 5 repo and the latest R RPMs

Marc Schwartz marc_schwartz at me.com
Fri Aug 21 21:23:46 CEST 2009

On Aug 21, 2009, at 1:00 PM, Hugh Brown wrote:

> Hi everyone -- I have a number of systems here running CentOS 5.2 and
> 5.3.  Recently, I tried adding a package unrelated to R and found that
> yum is complaining about the R repo.  Here's the error I get when
> running yum update:
>    ----
>    $ sudo yum update
>    [snip]
>    http://cran.r-project.org/bin/linux/redhat/el5/x86_64/repodata/primary.xml.gz 
> : [Errno -3] Error performing checksum
>    Trying other mirror.
>    primary.xml.gz  2.9 kB     00:00
>    http://cran.r-project.org/bin/linux/redhat/el5/x86_64/repodata/primary.xml.gz 
> : [Errno -3] Error performing checksum
>    Trying other mirror.
>    Error: failure: repodata/primary.xml.gz from CRAN: [Errno 256] No  
> more mirrors to try.
>    ----
> /etc/yum.conf has these lines:
>    ----
>    # PUT YOUR REPOS HERE OR IN separate files named file.repo
>    # in /etc/yum.repos.d
>    [CRAN]
>    name=CRAN
>    baseurl=http://cran.r-project.org/bin/linux/redhat/el5/x86_64
>    ----
> This error persists even after running "yum clean all" and "rm -f
> /var/lib/rpm/__db.00? ; rpm --rebuilddb".  I've disabled the CRAN repo
> and applied all available updates, and I still get these problems.
> I've checked with the folks at CentOS, and they suggested contacting
> the repo manager.
> Looking at the repo itself, it seems that there's a new version that
> was uploaded 10 days ago; I'm wondering if the new package or repo
> files are causing me problems somehow.
> Has anyone else had this problem?  Is there something I need to do to
> make updates work?
> Please let me know if you need any further information, or if there's
> another person or mailing list I should be contacting.
> Thanks in advance for any help!


Take a look in /etc/yum.repos.d and see if there are any other yum  
config files (*.repo) with enabled repos that may be conflicting with  
the config you have in /etc/yum.conf.

You can use:

   sudo yum repolist

to get a quick list of repos that are enabled by default.

I would also remove the CRAN config from /etc/yum.conf and unless  
there is already one in /etc/yum.repos.d, create another (eg.  
CRAN.repo file) just for CRAN with the appropriate config information,  
including an explicit 'enabled=1' or 'enabled=0' directive. For  
several Fedora/RHEL releases, having separate yum config files, one  
per repo, is the preferred model.

An alternative, would be to not use the CRAN repo and add the EPEL (https://fedoraproject.org/wiki/EPEL 
), which has R and other add-on packages that are not part of the  
default RHEL/CentOS distribution. Instructions on how to set up and  
use the EPEL are on the page linked above.

I am also cc:ing Martyn Plummer and Bob Kinney here, just in case they  
have other ideas or are aware of other issues that may be relevant.


Marc Schwartz

More information about the R-help mailing list