[R] ubuntu system refuses to update packages

Leon Yee yee.leon at gmail.com
Mon Nov 10 06:45:13 CET 2008

Dirk Eddelbuettel wrote:
> On 9 November 2008 at 20:35, Alan Jackson wrote:
> | There must be a simple answer to this.
> | 
> | I'm running ubuntu gutsy, currently have 2.7.2 loaded, but the update
> | tools refuse to update it, and don't tell me why. With apt-get I get :
> | 
> | [668 ~]$ sudo apt-get -u -V --simulate dist-upgrade
> | Reading package lists... Done
> | Building dependency tree       
> | Reading state information... Done
> | Calculating upgrade... Done
> | The following packages have been kept back:
> |    r-base (2.7.2-1gutsy0 => 2.8.0-1gutsy1)
> |    r-base-core (2.7.2-1gutsy0 => 2.8.0-1gutsy1)
> |    r-base-dev (2.7.2-1gutsy0 => 2.8.0-1gutsy1)
> |    r-cran-rpart (3.1.41-1gutsy0 => 3.1.42-1gutsy0)
> |    r-recommended (2.7.2-1gutsy0 => 2.8.0-1gutsy1)
> | 0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
> | 
> | If I use a gui package manager, it tells me the update will break
> | the installation and refuses to go forward, but doesn't show what the
> | issue is.
> In cases like this just take the set of packages and pass them directly to
> 'sudo apt-get install' ie
>    $ sudo apt-get install r-base r-base-core r-base-dev r-cran-rpart r-recommended
> which will show which packages this will install (as new), upgrade, or
> remove, if any.  It still allows you to pack out if you so choose.
> In this case it is probably 'just' a fortran or c++ library transition.  If
> you are still running gutsy you are also now two Ubuntu releases behind so
> you may want to consider upgrading to hardy and/or intrepid.
> By the way, this would have a good question for the r-sig-debian list.
> Hth, Dirk


    I encountered similar problems:

apt-get install r-base-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
   r-base-core: Depends: tcl8.5 (>= 8.5.0) but it is not installable
                Depends: tk8.5 (>= 8.5.0) but it is not installable
E: Broken packages


deb http://mirror.optus.net/ubuntu/ gutsy-security main restricted 
universe multiverse
deb-src http://mirror.optus.net/ubuntu/ gutsy-security restricted main 
multiverse universe

deb http://mirror.optus.net/ubuntu/ gutsy universe main
deb-src http://mirror.optus.net/ubuntu/ gutsy universe main
deb http://mirror.optus.net/ubuntu/ gutsy-updates universe main
deb-src http://mirror.optus.net/ubuntu/ gutsy-updates universe main

deb http://cran.ms.unimelb.edu.au/bin/linux/ubuntu gutsy/

deb http://security.ubuntu.com/ubuntu/ gutsy-security universe main
deb-src http://security.ubuntu.com/ubuntu/ gutsy-security universe main

It seems that R2.8.0 for gutsy is built on a system with tcl8.5 and 
tk8.5, which is not available in gutsy?

Best wishes,

More information about the R-help mailing list