[R] RdbiPgSQL in R 2.4.1

Seth Falcon sfalcon at fhcrc.org
Mon Feb 5 19:07:15 CET 2007

Hi Eduardo,

It would probably be best to send question regarding Bioconductor
packages to the bioconductor email list.

"Eduardo Dutra de Armas" <eduarmasrs at yahoo.com.br> writes:

> Hi R-users
> I recently downloaded RdbiPgSQL 1.8.0 and Rdbi 1.8.0 from Bioconductor to be
> installed under R 2.4.1.
> When requiring RdbiPgSQL an error message is showed as follows:
>> require(RdbiPgSQL)
> Loading required package: RdbiPgSQL
> Error in library(package, lib.loc = lib.loc, character.only = TRUE, logical
> = TRUE,   :
>              RdbiPgSQL is not a valid package  installed < 2.0.0?
> There is no issue about version restriction in Description file.

What OS are you running on?  How did you install the packages?  I'm
not able to reproduce the message you posted.

Perhaps try reinstalling using the biocLite install script.  Like

    biocLite(c("Rdbi", "RdbiPgSQL))

NB: normally, you don't need to specify dependencies, but this way it
will reinstall Rdbi as well in case you have a bogus install...

+ seth

More information about the R-help mailing list