[R] Installing 2.4.0

Denise Mauldin dmauldin at fhcrc.org
Tue Nov 21 23:18:59 CET 2006


I'm trying to install R 2.4.0 on a SunOS 5.10 Generic_118833-24 sun4v 
sparc SUNW,Sun-Fire-T200 machine.  The machine has gcc version 3.3.2 and 
gcc version 2.95.3 20010315 (release).  When I try to compile using 3.3.2 
I get an error with signal.h included from dcigettext.c.  When I compile 
using gcc 2.95.3 I get an error with va_copy.

"Undefined symbol va_copy first referenced in file connections.o
 ld: fatal: Symbol referencing errors.
 No output written to R.bin
 collect2: ld returned 1 exit status"

A friend suggested this was an error with stdarg.h and so I searched 
through the gcc2.95.3 directories and found a version of it and tried to 
include it using the -I and -L arguments to gcc, but this results in the 
same error.  I've tried using both the R-2.4.0 (R-latest) and R-patched 
gzip source files.

Is there any additional information that you need in order to 
help me?  What steps should I take to solve this problem? 


More information about the R-help mailing list