[R] arima fails when called from command line

markleeds at verizon.net markleeds at verizon.net
Tue Jun 20 21:10:35 CEST 2006

>From: Brian Dolan <buddha_314 at yahoo.com>
>Date: Tue Jun 20 12:54:14 CDT 2006
>To: r-help at stat.math.ethz.ch
>Subject: [R] arima fails when called from command line

hi : i had a similar problem a few weeks agowhen i was tryin g to use R CMD BATCH ( but when i sourced the copde at the r prompt everything worked fine ). eventually, i fiigured out that it had to do with a read.tale statement having a col.names argument that was too long for the script to handle. if it doesn't read in the data correctly,
this might be causing the arima failed message. that's
just a guess though. someone else may have a better idea.

>I'm sure there is no consistent way to reproduce this, but I'm hoping
>someone has some information.
>I have a time series we'll call y.  The data gets updated every day, so
>I run a cron job that fits and predicts from an arima(0,0,1) X (1,1,1)_7
>When I open R and run the script, it processes completely.  If I call
>the script via a crontab entry
>R --no-save --slave < myscript.R
>then the fitting of the arima model fails.  I have checked to make sure
>the shell is calling the correct version of R, so it should be no
>different than when I am using it interactively ...right?
>Thanks for your time on this,
>R-help at stat.math.ethz.ch mailing list
>PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html

More information about the R-help mailing list