[R] Solved - gnuclient problems witrh R/ESS in linux

Fredrik Lundgren fredrik.bg.lundgren at bredband.net
Wed Mar 30 19:04:25 CEST 2005


I found a way to make fix() and edit() work with gnuclient
in ESS-5.2.6/R-2.0.1/Xemacs-21.4.15-r3 on gentoo-linux.

When invoking R/ESS the following is induced by ESS
> options(STERM='iESS', editor='gnuclient -q')

It appears as if the problem is with 'gnuclient -q'
(whatever does -q signify?? From the man page it appears to disconnect 
the association between the opened buffer and gnuclient - which was teh 
very problem)
and when i changed a row in ess-5.2.6/lisp/gnu-cust.el
things worked in the expected way.
Change row

if (featurep 'xemacs) "gnuclient -q" "emacsclient"))) ;; unix


if (featurep 'xemacs) "gnuclient" "emacsclient"))) ;; unix

and all things work OK.

The only thing needed in init.el for gnuclient to work in this setup


and possibly

(setq gnuserv-frame (selected-frame))

if you whant the gnuclient frame to open within Xemacs

and no fuss with PATH

Many thanks to Richard M. Heiberger for all help!


PS A peculiar thing though - In the latest manual for ESS it's said:
4.9 Using emacsclient

When starting R or S under Unix, ESS sets options(editor="emacsclient").

Microsoft Windows, it will use gnuclient.exe rather than emacsclient,
but the same principle


but I got options(editor="gnuclient -q")

now changed to options(editor="gnuclient ")


----- Original Message ----- 
From: "Fredrik Lundgren" <fredrik.bg.lundgren at bredband.net>
To: "R-help" <r-help at stat.math.ethz.ch>
Sent: Monday, March 28, 2005 7:37 PM
Subject: [R] gnuclient problems witrh R/ESS in linux

> Dear list,
> Not strictly R ...
> In R on Xemacs with ESS (R-2.0.1, Xemacs-21.4.15-r3, ESS-5.2.6)
> on gentoo-linux
> when I use k<-edit(k) or fix(k)
> to change a small vector k <- c(1,2,3,4,5,6)
> the opened window (called '6b8b4567') appears not to be connected to 
> the
> gnuclient
> and I'm able to edit the file but has no instructions in the
> minibuffer
> and
> C-x # gives
> '6b8b4567 does not belong to gnuserv client'
> in init.el I have
> (require 'gnuserv)
> (gnuserv-start)
> (setq gnuserv-frame (selected-frame))
> Any help please?
> Fredrik
> ______________________________________________
> R-help at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! 
> http://www.R-project.org/posting-guide.html

More information about the R-help mailing list