[R] R CMD SHLIB setup problem...

Toby.Patterson@csiro.au Toby.Patterson at csiro.au
Tue Sep 14 03:26:28 CEST 2004

I've compared my Makevars to someone else's and we both have the same

CFLAGS+= -I$(RHOME)/src/gnuwin32/graphapp

So I assume this is correct? (And the compiler is definitely GNU make). 

When I tried to recompile another bit of C code I got the following

make: *** No rule to make target `C:/PROGRA~1/R/rw1081/src/include/R.h',
needed by `filter_norm.o'.

So it looks like its looking for the R 1.8.1 versions of R.h. I just
can't work out why. I've dumped SET to a file and checked that nothing
on the path or any of the environment variables point to the old
directory. It all looks OK to me. 

As far as I am aware nothing here uses the windows registry so I am
assuming there shouldn't be any problems there.  


-----Original Message-----
From: Duncan Murdoch [mailto:murdoch at stats.uwo.ca] 
Sent: Tuesday, September 14, 2004 10:58 AM
To: Patterson, Toby (Marine, Hobart)
Cc: r-help at stat.math.ethz.ch
Subject: Re: [R] R CMD SHLIB setup problem...

On Tue, 14 Sep 2004 10:29:31 +1000, <Toby.Patterson at csiro.au> wrote:

>When I try and compile a shared library (on WinXP) I get the following
>E:\data\proj>R CMD SHLIB toy_dll.c
>Makevars:1: *** missing separator.  Stop.
>Has someone else had this error and fixed it? 

Haven't had the error, but the usual suspects are:

 - You're getting the wrong make.  Follow the readme.packages
instructions for setting up your path, and make sure "make --version"
tells you you're running GNU Make.

 - Something has messed up your Makevars file.  Does it look normal in
a reasonable text editor?

Duncan Murdoch

More information about the R-help mailing list