[R]Update on: Installing the Rcmdr and tclk package

Gerald.Jean@spgdag.ca Gerald.Jean at spgdag.ca
Wed Jan 14 21:59:43 CET 2004

Hello R-users,

first thanks to all who responded my questions regarding the installation
of the Rcmdr and tcltk packages.  The problem is with the tclk package on
which Rcmdr depends.

Following Prof Ripley's advice I re-installed Tcl and Tk, compiling from
sources and making sure the "--enable-64bit" option of their configure was
set and setting the environment variable "CC" to "cc" since I want to
compile R in 64bit and
use the Sunpro "cc" compiler.  Everything worked fine. CDing to the tcl
directory and typing "wish8.4" at the Unix prompt started tk, similarly
tclsh8.4 started tcl.

I then rebuilt R from the sources again, setting the appropriate C and
Fortran flags in "config.site", as in the "R Installation and Admin" and
specifying the options:
"with-tcl-config=/path to the tclConfig.sh file" and
"with-tk-config=/path to the tkConfig.sh file" for configure.

configure still gave me the following warning:

checking for /home/jeg002/tcl8.4.5/lib... /home/jeg002/tcl8.4.5/lib
checking for /home/jeg002/tcl8.4.5/lib... /home/jeg002/tcl8.4.5/lib
./configure: .: /home/jeg002/tcl8.4.5/lib: is a directory
./configure: test: -lt: unary operator expected
./configure: .: /home/jeg002/tcl8.4.5/lib: is a directory
./configure: test: -lt: unary operator expected
configure: WARNING: Tcl and Tk major or minor versions disagree

I also had this message on the first built of R.  But looking up in
tclConfig.sh I get for version:

# Tcl's version number.

and in tkConfig.sh I get:

# Tk's version number.

sure look the same to me?  Then make worked fine as did make check, I only
got and error upon checking internet connection, which is problematic at
this time on our Sun server (I get the R, Tcl, etc. distributions through
Internet Explorer on my PC, which as a connection to the Unix machine).
Then make install worked fine, R seems to work fine, but again if I try to
attach the tcltk library I get:

> library(tcltk)
Error in firstlib(which.lib.loc, package) :
      Tcl/Tk support is not available on this system
Error in library(tcltk) : .First.lib failed

which I could predict of course since the "tcltk" file in the
.../library/tcltk/R had only the ".First.lib" function with the unique
command "stop(Tcl / Tk support blablabla)".

I am puzzled, and very frustrated, I have no idea what to look next, not
even what to think next!  Does the problem lie with the OS, Tcl/Tk, R, me
(most likely), something else?

Any insights very (extremely) welcome, thanks,

Gérald Jean
Analyste-conseil (statistiques), Actuariat
télephone            : (418) 835-4900 poste (7639)
télecopieur          : (418) 835-6657
courrier électronique: gerald.jean at spgdag.ca

"In God we trust all others must bring data"  W. Edwards Deming

More information about the R-help mailing list