[R] help.start( )

Marc Schwartz MSchwartz at medanalytics.com
Thu Sep 4 02:02:03 CEST 2003

On Wed, 2003-09-03 at 17:41, Ming wrote:
> Dear R experts,
> I installed R-1.7.1 on Linux (Red Hat 9.0) starting from R-1.7.1.tgz
> without a problem.  Then I fired up R and tried things and found that
> help.start( ) does not work.  I downloaded Sun Java j2re1.4.2,
> installed that and re-installed R-1.7.1 from scratch.  I tried
> help.start( ) again and the browser (Mozilla 1.2.1) crashed.
> I read about copying libjavaplugin_oji.so into mozilla/plugins and
> installed R-1.7.1 (again from scratch).  Mozilla still crashed.  Can
> you tell me how to make help.start( ) work in R-1.7.1?
> Thank you
> Ming Chow

You don't want to copy the file itself into the plug-in directory, but
create a 'symlink' to the file.

One of the things that you should consider (seriously) doing, is to
upgrade your mozilla version to 1.4. There have been notable (and
beneficial) updates to the browser since 1.2.x.

You will need to open a console window, su to root and change into the
mozilla/plugins folder, which should be something like:


Of course, adjust the 'mozilla-1.x' component to your actual path.

In that folder, in the console window as root, type:

ln -s /usr/path-to-java/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

That will create the symlink for the java plug-in. Adjust the
'path-to-java' above for your installation of java. Be sure that you use
the 'ns610-gcc32' path and not the others that may be present. This is a
version of the plugin that was compiled with the version of gcc that
comes with RH 9.

Once you have created the symlink, then try help.start() in R. If things
are functioning properly and the initial main page comes up, after you
click on "Search Engine & Keywords", you should see "Applet SearchEngine
started" on the mozilla status line.


Marc Schwartz

More information about the R-help mailing list