[R] problem building dvi and pdf documentation on Darwin 10.2.6

Mark E. Perkins perkinsm at bway.net
Sun May 18 20:10:48 CEST 2003

--On Saturday, May 17, 2003 23:16 +0200 Peter Dalgaard BSA
<p.dalgaard at biostat.ku.dk> wrote:

> "Mark E. Perkins" <perkinsm at bway.net> writes:


>> Transcript written on R-FAQ.log.
>> ../../bin/texi2dvi: tex exited with bad status, quitting.
>> ../../bin/texi2dvi: see R-FAQ.log for errors.
> It might be informative to take that hint since the log files are
> somewhat more verbose about exactly what is going on. 
> It's not your texinfo version -- mine is exactly the same. However,
> there are probably very few people running teTeX 2.x so there could be
> an obscure installation problem with that.
> It looks like your troubles begin where TeX is supposed to be
> processing R-FAQ.aux. It can happen that TeX gets wedged when there's a
> problem with that so you could try deleting it.

I should have mentioned that I had looked at the log file, but that it
really hadn't helped me any in terms of understanding the problem....

I *have* discovered that there is a problem with the index files. Running,
for example, 'make R-FAQ.dvi' in ..../manuals fails as noted previously.
The Makefile basically runs texi2dvi (with one argument), so if I try to
accomplish the same thing by hand and run

        tex R-FAQ.texi && texindex R-FAQ.?? && tex R-FAQ.texi ...etc

I get R-FAQ.dvi with table of contents (but note that R-FAQ does not build
an index). OTOH, if I do the same thing for R-admin (or any of the others),
texindex complains:

        texindex: R-admin.cp: not a texinfo index file
        Segmentation fault

If I make R-admin.cp a zero-byte file, I see the same result, but complaint
is about R-admin.vr. So it appears (to my TeX-deficient brain) as if tex
may be doing something funny with to the intermediate index files. On the
off chance that teTeX 2.0.2 is the problem, I built TeX from the web2c
distribution. I get the same result, but both are, in fact the same version
of TeX, i.e., both report:

-> cd proper-directory && ./tex --version
TeX (Web2C 7.4.5) 3.14159
kpathsea version 3.4.5

texindex from fink and texindex from the Darwin installation are both

-> cd proper-directory && ./texindex --version
texindex (GNU texinfo) 4.2

Lastly, here is R-admin.cp in its entirety (which looks like TeX stuff to
my untrained eye, and R-admin.vr is similar):

\entry{Obtaining R}{1}{Obtaining R}
\entry{Sources for R}{1}{Sources for R}
\entry{Installing under Unix}{2}{Installing under Unix}
\entry{MacOS X}{2}{MacOS X}
\entry{Help pages}{3}{Help pages}
\entry{Manuals, installing}{4}{Manuals, installing}
\entry{Installing under Windows}{5}{Installing under Windows}
\entry{Installing under MacOS}{6}{Installing under MacOS}
\entry{MacOS X}{6}{MacOS X}
\entry{Packages, installing}{7}{Packages, installing}
\entry{Packages, updating}{8}{Packages, updating}
\entry{Packages, removing}{8}{Packages, removing}
\entry{BLAS library}{10}{BLAS library}
\entry{LAPACK library}{10}{LAPACK library}
\entry{BLAS library}{14}{BLAS library}
\entry{MacOS X}{16}{MacOS X}
\entry{BLAS library}{16}{BLAS library}
\entry{LAPACK library}{16}{LAPACK library}
\entry{BLAS library}{17}{BLAS library}
\entry{LAPACK library}{17}{LAPACK library}

Once again, any pointers will be appreciated. I can't find older versions
of teTeX and web2c for Darwin to see if I can pinpoint the problem to my
"new" version of TeX.

Mark Perkins
perkinsm at bway.net

More information about the R-help mailing list