[R] problems compiling R on AIX5.1

Harald Servat Gelabert harald at cepba.upc.es
Mon May 5 17:45:03 CEST 2003


I'm trying to compile R (versions 1.6.0, 1.6.1, 1.6.2 and 1.7.0) on
our IBM Power3 Machine for an external user.

I always used to configure with 
./configure --prefix=/scratch_tmp/harald/instala

I've never achieved to compile 1.7.0 because it seems that a file 
called R.exp is missing (or maybe it's not well referenced on the

Output of make:

        xlc_r  -I. -I../../../src/include -I../../../src/include 
-I/usr/local/include -DHAVE_CONFIG_H    -O2 -qmaxmem=8192 -c dftables.c -o
        xlc_r -Wl,-brtl -Wl,-bdynamic -Wl,-bE:../../../etc/R.exp -Wl,-bM:SRE
-L/usr/local/lib -o dftables -O2 -qmaxmem=8192 dftables.o
ld: 0706-004 Cannot find or read export file: ../../../etc/R.exp
        ld:accessx(): A file or directory in the path name does not exist.
make: 1254-004 The error code from the last command is 255.


For this reason I tried to compile an older version (thos 1.6.x).
First with the XLC/XLF but seems it can't handle .lo files

        xlc_r -Wl,-bM:SRE -Wl,-H512 -Wl,-T512 -Wl,-bnoentry -Wl,-bexpall
-Wl,-bI:../../../etc/R.exp -L/usr/local/lib -o R_X11.so  dataentry.lo devX11.lo
rotated.lo rbitmap.lo -lSM -lICE -lX11  -ljpeg -lpng -lz  -lz -ldl -lm -lc
xlc_r: 1501-218 file dataentry.lo contains an incorrect file suffix
xlc_r: 1501-218 file devX11.lo contains an incorrect file suffix
xlc_r: 1501-218 file rotated.lo contains an incorrect file suffix
xlc_r: 1501-218 file rbitmap.lo contains an incorrect file suffix
ld: 0711-317 ERROR: Undefined symbol: .__fixsfsi
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information.
make: 1254-004 The error code from the last command is 8.

Finally I tried to compile with GNU C/F77 adding the flags described
in a pdf where describes how to compile R.

setenv MAIN_LDFLAGS "-Wl,-brtl"
setenv SHLIB_LDFLAGS "-Wl,-G"

p630n17:~/xremora>gcc --version
gcc (GCC) 3.1

It seems to compile correctly, but the when I use q() in the prompt on
R I receive a segmentation fault. Furthermore, I'm unable to run the
checks due to this segfault, but it seems that demo run fine.

I've also tried to configure with --enable-shared, but I receive the
same error (core dump).

Can anyone tell how I could solve this problem?

Best regards and many thanks,

             Harald Servat Gelabert (harald at cepba.upc.es)
   o//o      Centre Europeu de Paral.lelisme de Barcelona          CEPBA
  o//o       WWW...: http://www.cepba.upc.es       Tel: +34-93-401 74 23
 o//o        e-mail: suport at cepba.upc.es           Fax: +34-93-401 25 77
o//o  CEPBA  c/Jordi Girona, 1-3, Mòdul D6. E-08034 Barcelona, Catalunya

The optimist thinks that this is the best of all possible worlds,
and the pessimist knows it.
-- J. Robert Oppenheimer, "Bulletin of Atomic Scientists"

We scientists, whose tragic destiny it has been to make the methods
of annihilation ever more gruesome and more effective, must consider
it our solemn and transcendent duty to do all in our power in
preventing these weapons from being used for the brutal purpose for
which they were invented.
-- Albert Einstein,       "Bulletin of Atomic Scientists"

More information about the R-help mailing list