[R] Building R on Mac OS X-"dumping methods" problem

Tom Kennedy tom.kennedy at bigpond.com
Sun Oct 20 00:38:12 CEST 2002

I have done some more homework.
I am running macos X 10.2.1 on a G3 700MHz ibook.
Developer tool July 2002 with August update.

I get R by rsync. I have tried all three version released, pathched and 
devel and get the same problem with all of them.

If I run nm on methods.so, I get:

       $nm methods.so |grep R_initialize
       00002db8 T _R_initialize_methods_metadata

It is present but, is the leading underscore significant?

There is no 'ldd' on darwin but otool -L is the same I think. It gives 
the same output.

        $otool -L methods.so
         /usr/local/lib/R/bin/libR.dylib (compatibility version 0.0.0, 
      current version 0.0.0)
        /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current 
version 60.2.0)

This is a curious result since there is not currently a library at
/usr/local/lib/R/bin/libR.dylib since I have not install yet.
I did do a partial install and it made no difference.

If I look for libraries in R.bin, I get the following result and it 
looks OK to me. Likewise it is identical for the dynamic library 
libR.dylib. It is finding the dlcompat libdl, using the system ncurses, 
libc and libz library.

$otool -L R.bin
(compatibility version 2.0.0, current version 122.0.0)
         /opt/local/lib/libdl.1.dylib (compatibility version 1.0.0, 
current version 1.0.0)
         /usr/lib/libncurses.5.dylib (compatibility version 5.0.0, 
current version 5.0.0)
         /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, 
current version 60.2.0)
         /usr/lib/libz.1.1.3.dylib (compatibility version 1.0.0, current 
version 1.1.3)

In the R.bin, I looked for Call routine

$nm R.bin|grep Call
00002bd8 T _R_addCallRoutine
00071988 T _R_addTaskCallback
00071624 T _R_getTaskCallbackNames
000715c0 T _R_removeTaskCallback
00071810 T _R_taskCallbackRoutine
000860e8 T _RecordGraphicsCall
000712a4 T _Rf_addTaskCallback
00002c34 T _Rf_freeCallSymbol
000032c8 T _Rf_lookupRegisteredCallSymbol
00071480 T _Rf_removeTaskCallbackByIndex
000713a0 T _Rf_removeTaskCallbackByName
0005544c t _assignCall
00012ccc T _baseCallback
00085038 t _makeErrorCall
0005533c t _replaceCall

Does this look right?

I tested another .Call interface by running R and then loading library 
ctest. ansari uses a library call and I got this result for 

Warning message:
Cannot compute exact p-value with ties in: ansari.test.default(ramsay, 
Error in .C("pansari", as.integer(length(q)), p = as.double(q), 
as.integer(m),  :
         C/Fortran function name not in load table

Looks like this is not just a problem in metheds.so.
Could the configure process be going wrong? The R.bin seems
to work OK but it cannot load external dynamic libraries.

Regards Tom

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list