[R] Newbie Q: Help with loading libraries in Mac OS X

Adam Witney awitney at sghms.ac.uk
Thu Oct 3 14:42:13 CEST 2002

On 3/10/02 10:08 am, "Peter Dalgaard BSA" <p.dalgaard at biostat.ku.dk> wrote:

> Ali Al-Timimi <aaltimim at hotmail.com> writes:
>> I am trying to load two libraries (mclust and tcltk) in Mac OS X (10.1.5).
>> My R version is 1.5.1
>> I have tried both the Carbon version and the Darwin command line version =,
>> but I get the following errors:
> ....
>>> library(tcltk)
>> Error in firstlib(which.lib.loc, package) :
>>         no display name and no $DISPLAY environment variable
>> Error in library(tcltk) : .First.lib failed
> You need to have an X11 server running for tcltk to work. (Currently,
> at least. There are native Mac Tcl/Tk versions but to my knowledge
> that's not what the tcltk package links against.) Jan de Leeuw will
> know the details, and I believe he also wrote them down somewhere.

If you are on OSX then you can install x11 and tcl/tk using fink
(fink.sourceforge.net). I have not tried the libraries you are looking at
here, but I have several other tcl applications running nicely


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list