[R] dyn.load & DLL files created from LCC-WIN32 and Compaq Visual Fortran

Jonghyeon Kim jhkim at emmes.com
Thu Nov 7 22:41:51 CET 2002

Dear R-er;

Using LCC-WIN32, I compiled a C program and created a dll file.

In R prompt, I typed  	dyn.load("c:\\temp\\randu.dll")  ,  from which there
is no error message.
Then I typed            .C("set_randu", as.integer(123457)) , from which I
have the following error message:

Error in .C("set_randu", as.integer(123457)) :
         C/Fortran function name not in load table

 I also tried a command  		is.loaded(symbol.C("set_randu")), from which I
have the following error message

 [1] FALSE

Here is another Fortran example to explain my problem.
a Fortran program was compiled using Compaq Visual Fortran 6 and a dll file
was created.
In S+, I succesfully interfaced with the dll file  by   	dll.load.
Now I try R with the same dll file, but I have the same error as above.

Can anyone tell me what's going on in R?
Thanks in advance.


r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list