[R] Loading tcltk package fails on WinMe/Cygwin but works with Rgui

Henrik Bengtsson hb at maths.lth.se
Wed Mar 6 17:46:09 CET 2002

I am investigating how well R/tcltk is supported on different system and I
ran into the same problem as Christian Schulz reported on February 7, 2002.

I am using [R] v1.4.1 on WinMe and ActiveTcl 8.3.2. Loading tcltk within
Rgui works just fine and both demo(tkdensity) and demo(tkttest) works as
expected. However, when I start R from my Cygwin terminal dyn.load() fails
to load the library:

% R --vanilla

> library(tcltk)
Error in dyn.load(x, as.logical(local), as.logical(now)) :
  unable to load shared library
  LoadLibrary failure:  One of the library files needed to run this
application cannot be found.
Error in library(tcltk) : .First.lib failed

Trying to troubleshoot;

> file <- "C:/PROGRA~1/R/RW1041/library/tcltk/libs/tcltk.dll"
> file.exists(file)
[1] TRUE
> dyn.load(file)

gives the same error as above. Suspecting Cygwin paths where interacting
with the Windows paths, I also tried set the working directory to the
directory where the dll is and to load from there

> setwd("C:/PROGRA~1/R/RW1041/library/tcltk/libs/")
> file <- "tcltk.dll"
> file.exists(file)
[1] TRUE
> dyn.load(file)

but the same error. As I said, this works fine with Rgui. Any ideas?


Henrik Bengtsson

Dept. of Mathematical Statistics @ Centre for Mathematical Sciences
Lund Institute of Technology/Lund University, Sweden (+2h UTC)
Office: P316, +46 46 222 9611 (phone), +46 46 222 4623 (fax)
h b @ m a t h s . l t h . s e, http://www.maths.lth.se/bioinformatics/

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list