[R] dev.copy2eps() problem

Timur Elzhov Timur.Elzhov at jinr.ru
Thu Aug 1 17:00:42 CEST 2002

Hello experts!

I've tried to make single plot, but with changed ticks length,
and then copy them to file by dev.copy2eps(). Here is the code:

   x11 ( , 5, 5)
   par (tcl = +5) 
   plot (0)        # wow!  I see the ugly plot with great
                   # ticks on the graph viewport!  cool :)
   dev.copy2eps (file = "out.eps")

Well, I had a look at "out.ps" and .. wondered that ticks
look like as they would being set to there default value,
"tcl" = -0.5 !

Hmm.. well, I tried to make same thing by a bit different

    postscript (file = "out1.eps", onefile = FALSE)
    par (tcl = +5)
    plot (0)
    dev.off ()

All the OK!  All the ticks have an appropriate length,
tcl = 5!

Why?  What am I did wrong?

PS  I use the last R version, 1.5.1 under GNU/Linux on i386 platform.

Thanks a lot,

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list