[R] R and OS X

David Pearson david.pearson at mail.nerc-essc.ac.uk
Tue Apr 23 11:03:04 CEST 2002

Tristan Lorino wrote:
> >  Dears users,
> >  I'm trying to run R on a computer with OS X. I installed the R folder
> >  and the dylibs, where they must be installed. I updated my path, and
> >  R runs but tells me :
> >
> >  dyld: /usr/local/R-1.4.0/lib/R/bin/R.bin version mismatch for
> >  library: /usr/lib/libz.1.dylib (compatibility version of user: 1.1.3
> >  greater than library's version: 1.0.0)
> >
> >  The only thing I didn't do -- because I don't know how one can do
> >  this -- is to put /sw/lib first in the
> >  DYLD_LIBRARY_PATH environmental variable.

Hello Tristan,

I think your problem may be a different one. See item 5 of my
R installation notes below. (I copy the whole lot as other items
may be of interest also.)

The ReadMe.txt file of the Darwin installation says this:
"If R asks for a 
version of any of these dylibs which is named slightly differently
(for instance libz.1.dylib), then just put in a symbolic link in /sw/lib,
i.e. "ln -s libz.1.1.3.dylib libz.1.dylib"."

This is what I had to do to make R work.



1. Installed the binary files for R-1.4.0 today (now Thursday).
2. tried to run it today, got dyld errors.
3. Copied all the .dylibs into /sw/lib, as instructed.
4. Got dyld errors again.
5. Made symbolic links as instructed.
6. Now works, but gives runtime error:
/usr/local/R-1.4.0/lib/R/bin/pager: no such file or directory: /sw/bin/less
7. Fixed this by putting the correct path to "less" in
8. Now get postscript error.
9. Restart then OK.
10. Forgot to say that I tar'd the /sw/lib directory, and it is (I hope)
in this here directory now.


1. Tried to install the "as.date" etc. functions in the "date" package,
as follows:
(a)  Got date_1.2-12.tar.gz on desktop.
(b)  R CMD INSTALL date

2. Got errors saying gcc not found - actually need to pick up cc.
3. Tracked down the problem to
.. so copied this to Makeconf_as_installed and edited original
to change "gcc" to "cc" in both places.

4. Got another error, saying couldn't find perl.
5. Tracked down the problem to
.. so copied this to Renviron_as_installed and edited original
to change "PERL=${PERL-/usr/local/bin/perl}" to "PERL=${PERL-/usr/bin/perl}"
at its only occurence.

6. Installation then OK.

7. Ran R, did "library()" and saw "date" was there. Did "library(date)" and
accessed the date things OK. Can now do things like:

> mdy.date(10,29,65)
[1] 29Oct65

> mdy.date(4,9,2002) - mdy.date(10,29,65)
[1] 13311

> as.integer( mdy.date(10,31,1970) )
[1] 3956

David Pearson,              Phone: +44 (0)118  9318741
ESSC,                       Fax:   +44 (0)118  9316413 
University of Reading,      Email: dwcp at mail.nerc-essc.ac.uk
Reading RG6 6AL,           
UK.                         www.nerc-essc.ac.uk/~dwcp/Home.html
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list