[R] help with compiling R under hpux 10.20

rggefrm rggefrm at ucl.ac.uk
Tue Nov 13 19:47:06 CET 2001

Dear R users,

I tried to compile R under hpux 10.20 and have sveral problems. R-1.3.1
 making strdup.d from strdup.c
> >>         gcc -I. -I../../src/include -I../../src/include
> >> -I/usr/local/include -DHAVE_CONFIG_H   -g -O2 -c CConverters.c -o
> >> CConverters.o
> >>         gcc -I. -I../../src/include -I../../src/include
> >> -I/usr/local/include -DHAVE_CONFIG_H   -g -O2 -c Rdynload.c -o Rdynload.o
> >> Rdynload.c: In function `R_FindSymbol':
> >> Rdynload.c:781: `CFunTab' undeclared (first use in this function)
> >> Rdynload.c:781: (Each undeclared identifier is reported only once
> >> Rdynload.c:781: for each function it appears in.)
> >> *** Error exit code 

I heard from Luke Tierney that this is a known problem. I tried to compile 
R-1.2.3. Compiling went through without error however 

make check 

virol-s1 64: make check
running code in base-Ex.R ...
        ../../bin/R --vanilla < base-Ex.R > base-Ex.Rout
*** Error exit code 2

*** Error exit code 1

*** Error exit code 1

*** Error exit code 1

*** Error exit code 1

Nevertheless I did 

make install

and started R with:


which produces the following error:

virol-s1 65: /usr/local/lib/R/bin/R
Fatal error: The X11 shared library could not be loaded.
  The error was can't open /usr/local/lib/R/bin/R_X11.sl

However the library excists in /usr/lib/R/bin

My question now. Has anyone been able to compile R under hp-ux 10.20,
and if yes which version was this.

I appreciate any thoughts

Framk Mattes
Department of Virology
Royal Free Hospital

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list