[R] failed rpm installation of R 1.2-1

Faheem Mitha faheem at email.unc.edu
Wed Feb 7 06:04:35 CET 2001

Dear People,

Just tried to compile an rpm for R 1.2-1 (using Albrecht Gebhardt's spec
file). The compile went successfully and produced a binary rpm, but when I
tried to install it, I got an error

error: failed dependencies:
        BEGIN is needed by R-base-1.2.1-1

I see this was also listed in the Requires list at the end of the rpm

Requires: /bin/sh /usr/bin/perl BEGIN ...

Of course I could force installation of the package, but I would like to
know what I am doing first. Albrecht does not say anything about BEGIN in
his spec file, so this must be some internal to R. Does anyone have any
idea what? I have no idea. 

                             Sincerely, Faheem Mitha.

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list