R-beta: compiling R-0.62.3 on SuSe Linux

owner-r-help@stat.math.ethz.ch owner-r-help at stat.math.ethz.ch
Wed Sep 30 17:09:56 CEST 1998

On my RedHat 5.1 machine at the office I am happily using R
installed from Martyn Plummer's RPM's of R-62.3 for RH 5.1

At home I have SuSe Linux 5.3 on my PC and as RH 5.1 is libc6
based and SuSe 5.3 is still libc5 based the RH 5.1 RPM's do
not install and work on SuSe (even though they have a test
version of glibc).

So I downloaded R-0.62.3.tgz from www.ci.tuwien.ac.at/R and
tried to compile it on SuSe. This gives a lot of errors that
I don't understand because I don't program in C/C++ and only
vaguely comprehend the workings of 'configure' and 'make'.

I used the available 'gcc-' and 'g77-'.
SuSe has 'libc-5.4.46-1'.

I uncompressed/untarred the 'tgz' to /usr/local/ and then
ran ./configure in the resulting directory /R-0.62.3
This seemed to complete OK but consulting the config.log
file showed things like:

>>configure:1888: gcc -o conftest -g -O2   conftest.c -ldxml
>>  -ldl -lncurses -lm  1>&5 
>>/usr/i486-linux/bin/ld: cannot open -ldxml: No such file or directory
>>configure: failed program was:
>>#line 1881 "configure"
>>#include "confdefs.h"

I still tried to run 'make' and this resulted in failure messages
of which I include the following:

>>make[3]: Leaving directory `/usr/local/R-0.62.3/src/appl'
>>cd unix; make
>>make[3]: Entering directory `/usr/local/R-0.62.3/src/unix'
>>gcc -g -O2  -I../../src/include  -c dataentry.c
>>In file included from dataentry.c:24:
>>dataentry.h:22: X11/X.h: No such file or directory
>>dataentry.h:23: X11/Xlib.h: No such file or directory
>>dataentry.h:24: X11/Xutil.h: No such file or directory
>>dataentry.h:25: X11/keysym.h: No such file or directory
>>dataentry.h:26: X11/cursorfont.h: No such file or directory
>>make[3]: *** [dataentry.o] Error 1
>>make[3]: Leaving directory `/usr/local/R-0.62.3/src/unix'
>>make[2]: *** [build] Error 2
>>make[2]: Leaving directory `/usr/local/R-0.62.3/src'
>>make[1]: *** [R] Error 2
>>make[1]: Leaving directory `/usr/local/R-0.62.3'
>>make: *** [all] Error 2    

Can somebody give me some idea of what is going wrong and what
to do to correct it.
I can't find the files "X.h, Xlib.h, Xutil.h, keysym.h, cursorfont.h"
either in RH 5.1 or SuSe 5.3. 

R-0.62.3.tgz only contains R-base. So if I get it working
where can I find the sources for the contributions and VR.
I can't find them on tuwien.      
Alexander Volovics
Dept of Methodology & Statistics
Maastricht University, Maastricht, NL
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list