R-beta: trouble compiling 0.62.3 on SunOS 4.1.4: lgamma conflicts

Ben Bolker ben at eno.Princeton.EDU
Thu Sep 10 15:58:15 CEST 1998

  I've recently tried to get 0.62.3 up on our Suns (4.1.4, using gcc; I'm
also having trouble with a Solaris 2.6 compile but I haven't given up hope
on that one yet) -- the last compile I did was 0.61.1, which worked

 ./configure --prefix=/usr/local/apps/R/R-0.62.3  [--with-g77]
  (tried both with and without g77, eventually get to the same place),
I get a conflict with the function lgamma being defined both in R and in
the system's libm.a file: 

cd main; make
g77  -o R.binary arithmetic.o  [snip] version.o ../lib/libgraphics.a
../lib/libunix.a  ../lib/libappl.a  ../lib/libmath.a -lSM -lICE
-L/usr/lib/X11 -lX11  -ldl -ltermcap -lm
collect2: ld returned 2 exit status
ld: /lib/libm.a(lgamma.o): _gamma: multiply defined
ld: /lib/libm.a(lgamma.o): _lgamma: multiply defined
*** Error code 1

  lgamma appears to be defined both in 

    ./src/nmath/lgamma.c  -> ./src/lib/libmath.a

   and in /lib/libm.a.

We have a fairly poorly configured system, but 0.61.1 compiled fine;
that version appeared to have a corresponding ./src/math/lgamma.c that was
compiled into ./src/lib/libmath.a, but didn't cause a conflict.

  Any ideas?  I hope I'm not being really foolish.

Benjamin Bolker          Dep't of Ecology and Evolutionary Biology,
ben at eno.princeton.edu    Princeton University
tel: (609) 258-6886,     fax: (609) 258-1334

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list